Reply To: Failed to scan Dynamixel motors, Broadcast ping failed , result : -30022018-10-27T17:16:19+00:00

Forums Niryo One Troubleshooting Failed to scan Dynamixel motors, Broadcast ping failed , result : -3002 Reply To: Failed to scan Dynamixel motors, Broadcast ping failed , result : -3002

BManCan
Participant
Post count: 13

Update on my axis 6 motor connection issues. I updated the ID from 6 to 1 in hopes that my XL320 servo was still on the default address. The update was made to both of these files through ssh on the raspberry pi:

  • ~/catkin_ws/src/niryo_one_bringup/config/v2/niryo_one_motors.yaml
  • ~/catkin_ws/src/niryo_one_driver/include/niryo_one_driver/dxl_communication.h

Then a recompiled as suggested in your post above (thanks). Unfortunately this did not seem to resolve my issue with motor connection on axis 6. I still believe that somehow the XL320 is not configured to the correct address, but I do not know what address it is on.

As a last resort, I tried using one of my new XL320 servos that I purchased for Gripper 2 and Gripper 3 use since it will be on ID1. This worked perfectly with the changes I made to set axis 6 to work on ID1.

So at this point I can’t get either of the supplied XL320 servos (axis 6 and gripper 1) to communicate, but I have the robot arm working without any tools attached. One interesting thing I found was that if I plug in either XL320 servo on its own, I get the motor connection missing on axis 6 message, but if I plug in both servos then the message changes to DXL communication failure (Failure to Scan DXL motors). I wonder if this means they are both on the same unknown address.

Looking forward to some help with identifying and resetting the IDs for the XL320 servos provided.

 

  • This reply was modified 2 weeks, 3 days ago by  BManCan.