Auto Calibration failed , hand broken :(2018-11-11T14:20:39+00:00

Forums Niryo One Troubleshooting Auto Calibration failed , hand broken :(

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • wodcleaner
    Participant
    Post count: 17

    Hi there , I bought the Maker Kit and build Niro One by myself  with printed parts in Black and White.

    Looks very nice 🙂

    But I have a big problem with the Auto Calibration Function.

    Manually Calibration won’t work , cause I have the printed parts without the marked points 🙁

    Always I start auto calibration the arm goes down to the base at the end of calibration, so the robots hand broke after the second time 🙁

    I don’t know what’s the problem and why he did it…

    I attache a youtube Video so you can see.

    Thanks for help

    Greetings Christopher

    Link:

    https://youtu.be/jtXufPG20RQA

    wodcleaner
    Participant
    Post count: 17

    Or do i mount the large spring in the  shoulder the wrong way?

    Cause if the Robot is powered off the the arm lowers automaticly… Or is that correct?

    Edouard Renard
    Keymaster
    Post count: 122

    Congrats on printing the robot, it looks really nice on black and white!

    Actually this issue has been fixed (you can find it on our github, but it’s not been released yet on new SD cards).

    Currently the torque on axis 2 is disabled in the middle of calibration, which should be fine, but can also be a problem if the torsion spring is a little bit strong, like in your case.

    Now, for calibrations, we keep axis 2 (and also axis 1) with torque ON during all the calibration, so you won’t have this problem anymore.

    What you can simply do is :

    – connect to the robot via ssh (tutorial here)

    – Execute the following commands: (make sure the robot is connected to a Wifi network and is not in hotspot mode –> LED should be green)

    sudo systemctl stop niryo_one_ros.service

    cd ~/catkin_ws/src

    git pull origin master

    cd ~/catkin_ws

    catkin_make -j2

    sudo reboot

    And that’s it!

     

    For the manual calibration, you actually don’t need the arrow, you just need to approximately align the axis:

    – axis 1 should be centered

    – axis 2 should have a 90° angle with the horizontal plane

    – axis 3 should be at the maximum position (down)

     

     

    wodcleaner
    Participant
    Post count: 17

    Thanks for your quick answer.

    I tried your advice but at the line

    „git pull Origin Master“

    i get a error msg :

    fatal: unable to Access ‘https://github.com/NiryoRobotics/Niryo_one_ros.git/’ Could Not resolve host: github.com

    wodcleaner
    Participant
    Post count: 17

    My mistake , the robot was still in Hotspot mode…

    Now everything is working fine , I updated the files an now Auto Calibration works perfect !!!

    Thank you very much.

    One last question about that large spring in the shoulder: if the Robot is powered off the the arm lowers automaticly… is that correct because of that spring?

     

    Edouard Renard
    Keymaster
    Post count: 122

    One last question about that large spring in the shoulder: if the Robot is powered off the the arm lowers automaticly… is that correct because of that spring?

    Yes, no problem about that!

     

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.