Can we run `sudo apt-get install` on Niryo?2018-08-02T05:57:46+00:00

Forums Niryo One Programming Niryo One Can we run `sudo apt-get install` on Niryo?

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • ng17
    Participant
    Post count: 1

    When I run sudo apt-get install some_package, it says.
    E: dpkg was interrupted, you must manually run ‘sudo dpkg –configure -a’ to correct the problem.
    However, if I do sudo dpkg --configure -a, I cannot use the robot anymore and some error happens. I have to rewrite the image to the SD card. I only tried that once and wouldn’t try to reproduce this if it is a known issue. Any experience or suggestions? Thanks!

    Edouard Renard
    Keymaster
    Post count: 123

    Hi,

    This is a problem related to Ubuntu apt, and this can happen sometimes. Usually, running sudo dpkg --configure -a will fix the issue. You may also have some apt processes still running. You can locate them with ps aux | grep apt, and terminate them if necessary with kill -9 process_number

    If you get the same error again and you don’t know what to do, please post more details about the errors you’re having, so we can help you debug more !

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.