NiryoOne automatic calibration gripper interference2018-10-15T17:35:49+00:00

Forums Niryo One Troubleshooting NiryoOne automatic calibration gripper interference

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • FindingNiryo
    Participant
    Post count: 44

    In order to remotely use the robot arm, automatic calibration must be used.

    Gripper #1, #2, #3, electro-magnet, & suction cup all collide with robot base during auto calibration.

    Edouard Renard
    Keymaster
    Post count: 106

    I guess the problem you get is that once axis 2 has reached its limit, the torque of the motor is disabled. Hence, the axis will move forward due to the torsion spring, and it will make the tools collide during the 1st phase of calibration, and also when the robot is coming back to home position. Let me know if that’s not what you observe.

    We have seen the same thing and have fixed that in the ROS code running on the Raspberry Pi. We’ll release that in the next software version, until then you can still update your ROS stack. Connect with ssh to the RPi, go in catkin_ws > src, and “git pull origin master”. You can now restart the robot.

    The fix is to always keep the torque ON on axis 2 during the calibration, so no tool will collide.

    Note that it’s recommended to run auto-calibration without any tool, but as you stated in your case you don’t have much choice.

     

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.