Forums Niryo One Programming Niryo One scipy.optimize error

Viewing 1 post (of 1 total)
  • Author
    Posts
  • wyojustin
    Participant
    Post count: 16

    I get an error when I attempt to import scipy.optimize on the Niryo One.   Reinstalling scipy did not help.  I had to copy/paste the python code from here as a temporary work around https://github.com/scipy/scipy/blob/v1.2.0/scipy/optimize/optimize.py#L2011-L2087

     

    >>> import scipy.optimize
    Traceback (most recent call last):
    File “<stdin>”, line 1, in <module>
    File “/usr/lib/python2.7/dist-packages/scipy/optimize/__init__.py”, line 233, in <module>
    from ._minimize import *
    File “/usr/lib/python2.7/dist-packages/scipy/optimize/_minimize.py”, line 26, in <module>
    from ._trustregion_dogleg import _minimize_dogleg
    File “/usr/lib/python2.7/dist-packages/scipy/optimize/_trustregion_dogleg.py”, line 5, in <module>
    import scipy.linalg
    File “/usr/lib/python2.7/dist-packages/scipy/linalg/__init__.py”, line 174, in <module>
    from .misc import *
    File “/usr/lib/python2.7/dist-packages/scipy/linalg/misc.py”, line 5, in <module>
    from .blas import get_blas_funcs
    File “/usr/lib/python2.7/dist-packages/scipy/linalg/blas.py”, line 155, in <module>
    from scipy.linalg import _fblas
    ImportError: /usr/lib/arm-linux-gnueabihf/libgfortran.so.3: invalid ELF header
    >>>

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.