Forums Niryo One Troubleshooting V2 Rasperry Pi CPU over-heating "Rpi temperature is really high !"

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • FindingNiryo
    Post count: 91

    V2 robot power-up connected to Wifi (green LED) no activity: RP3 heats up in air conditioned office:

    67 Celsius after a few minutes with no movement and no fans running.  Reaching 71C after an hour.

    Turn off [learn mode] {engage torque & start fans} CPU temp drops to 59.

    Rasperry Pi fan should probably always be running.

    Edouard Renard
    Post count: 219

    We have disabled all fans on Niryo One during learning mode so the robot doesn’t make noise. It can be helpful to know whether the robot is in learning mode or not, but the main reason is that the noise gives you headache when you are working in a not-so-noisy environment 🙂

    Usually the Raspberry Pi should not reach more than 70°C. But if it happens in your case, you can change this file directly on the Raspberry Pi, and reboot.

    You can replace the set_fans function by:

    def set_fans(self, activate):
    GPIO.output(FAN_1_GPIO, GPIO.HIGH)
    GPIO.output(FAN_2_GPIO, GPIO.HIGH)


    This will make the fan in the base always ON. You can also add other fans (there are some available slots) if you want to.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.