1. Home
  2. Docs
  3. Niryo One
  4. Update your robot
  5. Software versions compatibility

Software versions compatibility

For Niryo One to run correctly, all software versions need to be compatible:

  • Niryo One Studio
  • Niryo Raspberry Pi 3 image
  • NiryoStepper image (for all NiryoStepper motors)

You’ll get a popup message inside Niryo One Studio if incompatible versions are detected.

The version in bold and green is the latest stable (and recommended) version to install.

Niryo One Studio Niryo Raspberry Pi 3 image Niryo Stepper firmware
2.2.1
2.2.0
2.0.0
2.2.0
2.1.1 2.1.0
2.1.0
2.0.0 2.0.0
1.1.0 1.1.0 1.1.0

How can we help?